Mikrotik OpenVPN 互联带宽只有3Mbps解决方法

分类:技术 114浏览

两台Mikrotik Route 使用OpenVPN建立Server和Client,连接建立方式TCP,在国内公网(电信到移动)通讯中两端只有3Mbps(320kb-380kb)左右的传输速率,而且跑不起来,两端的带宽上传下载带宽都远高于OpenVPN速率的宽带冗余。

确认:

1、设备是2022年/2024年最新的,不存在性能问题。
2、带宽或对应协议没被上层ISP QOS。

解决方法一:

两端直接在winbox->Queues,Queue Types 内将default kind:pfifo默认设置的50 packets 设置为250。

解决方法二(推荐):

一、在OpenVPN Server端进行

1、新建一个Queue Types,并修改出口网卡使用的队列类型

   
/queue type add kind=pfifo name=ovpn-queue pfifo-limit=250

2、Winbox到Queues -> Interface Queues,将OpenVPN服务出口(公网IP出口的网卡)复制名字,并替换下面ether1

/queue interface set ether1 queue=ovpn-queue

服务器这边设置完了,。

二、在OpenVPN Client端进行

1、新建一个Queue Types

 
/queue type add kind=pfifo name=ovpn-queue pfifo-limit=250

2、Winbox到Interfaces -> Interface ,将OpenVPN名字复制,并替换下面OpenVPN-CQ

/queue interface set OpenVPN-CQ queue=ovpn-queue

客户端这边设置完了。

三、重新建立连接即可

实测宽带速率现有的设备可以可以跑满。

注意:两端都需要设置,否则速度起不来。

原因和参考文献:https://forum.mikrotik.com/viewtopic.php?t=146103