Proxmox 换源后提示 python3 is to be installed

分类:笔记 681浏览

刚开始换源的时候安装CEPH提示类似错误:

ceph-common is already the newest version (15.2.15-pve1).
ceph-fuse is already the newest version (15.2.15-pve1).
gdisk is already the newest version (1.0.6-1.1).
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
python3-cffi-backend : Depends: python3 (< 3.8) but 3.9.2-3 is to be installed
python3-distutils : Depends: python3 (< 3.8) but 3.9.2-3 is to be installed
Depends: python3-lib2to3 (>= 3.6.4) but it is not going to be installed
python3-markupsafe : Depends: python3 (< 3.8) but 3.9.2-3 is to be installed
E: Unable to correct problems, you have held broken packages.
apt failed during ceph installation (25600)

其实少了完整的,参考《Proxmox 7.2 换国内源安装》替换/etc/apt/sources.list为

deb http://mirrors.aliyun.com/debian/ bullseye main non-free contrib

deb-src http://mirrors.aliyun.com/debian/ bullseye main non-free contrib

deb http://mirrors.aliyun.com/debian-security/ bullseye-security main

deb-src http://mirrors.aliyun.com/debian-security/ bullseye-security main

deb http://mirrors.aliyun.com/debian/ bullseye-updates main non-free contrib

deb-src http://mirrors.aliyun.com/debian/ bullseye-updates main non-free contrib

deb http://mirrors.aliyun.com/debian/ bullseye-backports main non-free contrib

deb-src http://mirrors.aliyun.com/debian/ bullseye-backports main non-free contrib

就可以了